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Deleted Cyberstation personnel objects remain

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Deleted Cyberstation personnel objects remain

Picard Product_Support
‎2018-09-06 02:43 PM

Last Updated: Administrator DavidFisher Administrator ‎2019-11-08 01:11 PM

Issue

Cannot delete personnel. A personnel object will not be deleted due to distribution failures.

Product Line

Andover Continuum

Environment

Cyberstation

Cause

If a person has an area assigned and the controller or door has been deleted, the distribution to remove that person from that controller cannot be accomplished successfully.

Resolution

First, remove all areas from the personnel object before deleting the object. This is by design. The reasoning behind this is to allow a person to be removed from the network before disabling access.

Other things to check if distributions are failing:

  1. If running MSDE or SQL2000:
    1. Check to make sure the Agent is running.
    2. Check for duplicate tables and make sure they're all DBO
    3. Check Security Continuum DB make sure there is only one DBO linked to Andover97.
  2. If using SQL 2005:
    1. Look at the jobs under the Agent. They trigger every 5 minutes and are responsible for the task of deleting the personnel objects marked for deletion. At times there are errors for why the jobs are not running properly.

If the above steps do not correct the issue then it could be an issue with the database. The PSS engineer may request the database to perform analysis to reproduce what is happening and offer suggestions to correct the problem.

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