Issue
Security Expert and Security Expert Data Sync Service are running and operational. After a while, the Data Sync Service stops synchronizing. Reviewing the Data Sync Service log file indicates that the connection was lost and that the operator username or password are incorrect.
[WARN ] [0 ] - Failed to get Operator where ID = 6. Error Code: 8 (Connection lost/not logged on)
[ERROR] [0 ] - Incorrect username or password, or the operator does not have access. Error Code: 0 (Error).
Restarting the entire system or the Security Expert Data Service resolves the problem.
Product Line
Security Expert
Environment
- Multiple Security Expert Clients
- Security Expert Data Sync Service
Cause
The number of concurrent clients has exceeded the licensed limit.
The Data Sync Service will make a connection each time it synchronizes and then close that connection when finished. If there are no client licenses available for it to use when attempting to connect then it will fail and present the following events in the log file.
[INFO ] [0 ] - Verifying product license information...
[WARN ] [0 ] - Failed to get Operator where ID = 6. Error Code: 8 (Connection lost/not logged on)
[ERROR] [0 ] - Incorrect username or password, or the operator does not have access. Error Code: 0 (Error).
[INFO ] [0 ] - Next sync will begin at 24/07/2019 9:42:59 AM
Each Security Expert Client connection will take up a client license. If the SSN is enabled for three concurrent client connections this will allow for two Security Expert Clients and one Data Sync Service.
Resolution
- Purchase more client licenses (SX-CLNT) for the sites SSN.
- Ensure that no more than [one less than the maximum concurrent clients number] Security Expert Clients are running when the Data Sync Service is also running.