Issue
Crystal Reports in I/NET Seven Version 2.21
Environment
I/NET Seven version 2.21
Crystal Reports XI
Cause
Beginning with I/NET Seven version 2.21, the I/Net Seven Reports application uses Crystal Reports XI as the reporting engine.
Resolution
In order to create and run reports using Seven Reports, you must first install Crystal Reports XI support files unto your PC.
An installation program named SetupCrystalReportsXI.exe is included on I/Net’s installation disk for this purpose. When you execute this file, Microsoft Installer will launch and the necessary support files will be loaded onto your PC.
We recommend that you install Crystal Reports XI support files immediately after completing the I/NET Seven host software installation. If you forget to install the support files, you will receive the following message when you launch Seven Reports:
Crystal Reports Support files must be installed. Run CrystalReportsX1_Support Files.msi found on the Support Folder on the CD.
If you see this message, click OK and install the support files from I/Net’s installation disk. To install Crystal Reports XI support files:
-
Prepare to install the support files as follows:
- Close all other applications running on your system, including virus-checking software.
- Insert the I/NET Seven CD-ROM into your CD-ROM drive.
- If I/Net’s Setup program automatically launches, cancel it at the first screen that offers a Cancel button.
- Explore the CD-ROM and locate the following folder: d:\Support\SevenReports\CR_XI (where d: is the letter designation of your CD-ROM drive)
- Within this folder, execute the following file:SetupCrystalReportsXI.exe. This causes Microsoft Installer to launch and begin installing the support files.
- Follow the onscreen prompts to complete the installation process.