Issue
Continuum general preferences show the system is configured to purge extended log data after X days, yet the extended log data is not purged.
Product Line
Andover Continuum
Environment
- CyberStation
Cause
LAN System
The SQL agent responsible for purging extended log data is missing or disabled.
For Single User system see Stand Alone Continuum using SQL Server 2005 Express is not purging the ExtendedLog table
Resolution
LAN Systems (for Single User see Stand Alone Continuum using SQL Server 2005 Express is not purging the ExtendedLog table)
In SQL Server Management Studio expand SQL Server Agent, then expand Jobs
If ExtLog_Purge_ContinuumDB job is present verify its properties (see image below), make sure the job is enabled and properly configured to run.
If the job does not exist it can be recreated by following these steps:
- Close ALL Continuum Cyberstations/Web Client
- From SQL Server Management Studio run the following query against the ContinuumDB update ACDBVersion set ACDBVersion = 0
- Run Continuum DB Initialization and update the database from the server tab, when prompted to run the ImportExport fixup tool select NO
- Verify the job was created then run Continuum