Issue
Investigating event with EBO Webstation and need to collect logs for Product Support to assist.
Product Line
EcoStruxure Building Operation
Environment
Building Operation Webstation
Cause
Product Support requests logs to investigate an event in EBO Webstation
Resolution
Opening Developer Tools in Google Chrome or Microsoft Edge
- Open browser
- Hit F12 or Ctrl+Shift+I to toggle open and close the Developer Tools section
Note: In Microsoft Edge, one can use F12 if you check to Remember my decision and click the Open DevTools button
Collect Information from Developer Tools - Console
- Open the browser's Developer Tools
- Select the Console tab. NOTE: Exceptions from the server or client-side issues will be shown in the console.
- Select inside the console tab, hit Ctrl-A to Select All, hit CTRL-C to Copy, and in any text editor, hit CTRL-V to Paste. Save the file. NOTE: In this example, there are no exceptions to be saved.
Collecting Network Logs
The communication between the server and client can be logged. This can provide essential information about the information sent from the client to the server and how the information is parsed by the client.
It can be useful to:
- take a network log while reproducing the issue
- clear the application cache
- then take a new network log.
Preparing and saving the network log
- Click the Network tab.
- Make sure network traffic is being recorded (toggled with ctrl+E)
- Clear the network log by clicking the Clear symbol in the upper left
- Open the page or object representing the issue
- Carry out steps to reproduce the issue
- Stop the recording (toggled with ctrl+E)
- Click Export HAR... to save the HAR file
Clearing the application cache and type information
- Click the Application tab
- Click the Application - Storage section
- Ensure ALL boxes are checked
- Click Clear site data. NOTE: This will log you out and you need to log back in