Issue
Alarms cease to display and Continuum Workstation reports offline in the Workstation editor but appears as online to the CX controllers.
Environment
Continuum Workstation
Cause
On sites where this has been detected, there were alarms setup, the eventnotification settings were set for multiple entry, there was no recipient configured, and the deactivate settings required acknowledgement. This type of configuration will allow the active alarm count in the system to increase with each alarm. The active alarm buffer in the workstation by default is 3000 and when exceeded can cause the WS to appear as offline.
Resolution
NOTE: Before any query or access of a database make sure that you have a recent known good backup.
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To test for this situation, run the following query from the database:
Select count(*) from alarmevent where active = 1 - To fix this situation, correct the incorrectly configured event notifications to avoid the same problem.
- Shutdown all CyberStations.
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Run the following query on the database:
Update alarmevent set active = 0 where active = 1 - Restart Continuum.