Warning
Potential for Data Loss: The steps detailed in the resolution of this article may result in a loss of critical data if not performed properly. Before beginning these steps, make sure all important data is backed up in the event of data loss. If you are unsure or unfamiliar with any complex steps detailed in this article, please contact Product Support for assistance.
Issue
Access Expert uses Docker containers and images for the Bosch and Schindler integrations and at times the virtual machine image(s) need to be updated.
Product Line
EcoStruxure Access Expert
Environment
Access Expert Hosted V3
Cause
Feenics updates virtual machine images which requires an update
Resolution
Feenics may update a Docker image for one of their integrations.
Note: A Docker software update may be indicated in the bottom right of the Docker Window
This is only a software update for Docker and will not update the container image.
An image update requires a command to Pull the image down from Feenics.
The Docker software update is not required to update the Docker Image.
(see yellow highlight in the snapshot below)
Here are the instructions to update the Docker Container Image to the (latest)
Open Docker Desktop for Windows
1. Under Containers, make note of the current bosch service name Ex. AX-bosch-service1
2. Stop the container/service using the stop button
3. Click the Red Delete button above the container
Click Delete Forever
No container after the delete
Image still shows
4. Delete the Image by clicking on the Red Delete button under Images
Select Delete Forever (Image)
Image deleted (See below)
5. Click on the Blue button 'Search images to run'
Type in the following to search for Images
feenics/keep-bosch:latest
6. Select the 'feenics/keep-bosch:latest' Image and Click PULL
You will see the progress of the image downloading
7. Click on Containers on the top left - the container will not be there
8. Click on Images and then Click the Play button on the Feenics/bosch entry
9. On the next screen, after selecting Play, select the down arrow next to Optional settings
Enter the original container name that was noted above i.e. AX-bosch-service1, Click Run
You will see messages from the bosch service startup
Although the image is updated and running, you will likely see an 81 exception error in the startup log (see highlight above). Here are some additional steps to finalize this process.
10. Check in Windows Services> Docker Desktop Service
One of the updates along the way may have changed the startup type to Manual
Double-click on the service and select Automatic for Startup type
Click Start (to start the service)
Click Ok.
11. Open Windows PowerShell in ADMIN mode (standard mode will not work)
Run the following command
docker run -d --restart unless-stopped --name feenics-bosch-service --env-file C:\ENV\env-us.txt feenics/keep-bosch
If you try to run the command with the same name as the original service, you will receive the following message in PowerShell
Successful running of the Power Shell command
This command ensures Docker runs with the parameters that are stored in c:\env-us.txt
12. Click on Containers, and there will be 2 Containers
Select the one that is NOT running and click the Red Delete button
The Delete Forever prompt comes up, select the Delete forever button
One container should remain and should be running
The panel should be online and communicating
13. Test and verify everything is working with the Bosch integration