Issue
Information needed to work with Access Expert Custom Forms
Product Line
EcoStruxure Access Expert
Environment
Access Expert V3 Hosted
Cause
Access Expert Custom Form configuration
Resolution
Forms can be designed and applied to maintain additional people & reader information outside of traditional documentation or notes. Unlimited customer forms/fields can be added to the system and associated with a person or reader. The layout of the forms can be built to accommodate customer needs and can even be segmented. A good practice is to group additional information into common groupings such as Car Information, Health Information or Department Information. This type of approach will make the data entry easier. Information captured in a Custom Form can also be searched on and reported on. Once a custom form is created it will be available for use from either the person menu or the reader menu. Custom fields can then be utilized for applications such as customizing people reports, capturing additional information about employees, doing system searches as well as badge designing.
New Custom Form
To start creating a custom form:
- Select the ‘General Configuration’
- Select "Custom Forms”.
- Click “Add Custom Form”.
- Choose which editor the form will apply
- Enter the name of the Custom Form in the Application Name.
- (OPTIONAL) Choose the casing for the form. This is only important when leveraging the API or LDAP integration.
- Click “Save” or “Save & Close”.
Below is an example of a Custom Form that has been created. The header, fields, titles, and placement of information on the form is customizable by clicking, dragging and dropping.
The initial series of editors that support the creation of the form are across the top of the screen.
- Add Text Box – Adds a free form text box.
- Add Combo Box – Adds a free form text box that allows for multiple pre-selected entries from a picklist.
- Add Date Time – Adds a time and date entry box.
- Add CheckBox – Adds a checkmark box.
- Add Group Box – Adds a split box where the top section can be used as a title then other fields can be added.
- Add Header – Adds a header field that can be used for a single line title.
Group Box
When one of the box types is added to the form, the Properties section can be used to apply additional information and modify the data as it resides in the box. Every Content field that is added to a Custom Form must have a name. In this example, we will add a Group Box to capture information about an employee.
- Clicking the ‘Add Group Box’ provided the initial field.
- The title was applied by clicking the blank box and adding the name in the Properties editor under Content. This information can also be positioned to the left, center, stretched or to the right. The overall box can be enlarged by clicking the perimeter and then dragging to the desired size.
Text Box
Additional fields of information can be added to the Group Box by clicking on the desired data field type and it is applied to the Group Box. To ensure the new field is added inside the perimeter of the Group Box make sure to click inside the Group Box prior to selecting the data field. The new field can be dragged into the Group Box if it is added outside the group box.
Once the field is added to the Group Box the Properties editor will allow the same type of modifications to be made. Once the new blank field is added you can click into the Header field under Content to apply a descriptive name. This same process can be repeated to add as many fields as needed.
Combo Box
A Combo Box is added to a Custom Form just like the other box types. With a Combo Box, the Properties editor will display a new field called Items. Clicking the “…” will allow the operator to add the information that will be available when data entry is being performed.
The completed form will look like this from the custom data menu on the cardholder.