Issue
A PCI I/O board added to allow a parallel port for a security key is not recognized by the key.
Environment
Continuum
Windows XP
Windows Vista
Windows Server 2003
Windows Server 2008
Cause
The default setup for the Sentinel driver does not configure the PCI port
Resolution
After adding a PCI I/O board to allow a parallel key, the security key is not recognized. Even if a printer works on this parallel port and another machine reads the key perfectly, the security key does not work. Uninstalling and reinstalling the Sentinel driver does not make a difference. The Sentinel driver needs to be configured to allow the parallel port to be accessed via the PCI bus. By default, only the ISA and USB port types are shown.
Follow these steps to add the port for the installed PCI board:
- From the Control Panel, double-click the System icon to open the System Properties page.
- Click the Hardware tab and then the Device Manager Button to open the Device Manager.
- Click the + sign next to Ports (COM & LPT) to expand the tree.
- Double-click on PCI Card (LPT1) to open the property sheet for the PCI adapter.
- Click on the Resources tab to see the resources used by the adapter.
-
Under Resource Settings, make note of the first number in the range of the first line.
Ex. I/O Range 0378-0374 (the number to make note of is 0378) - Next, Start the driver configuration utility, SetupSysDriver.exe. It is usually located at C:\Program Files\Rainbow Technologies\Sentinel System Driver
- Click the "Configure Driver" button, then click the "Add" button.
-
Enter the I/O address of the PCI parallel port adapter into the "Bus Address" field.
Ex. 0378. - For Port type select PCIbus and Click on OK
It will show that a User Created port has been added at address 0378. The Sentinel System Driver should now be configured to use the Parallel PCI adapter.