Welcome to the new Schneider Electric Community

It's your place to connect with experts and peers, get continuous support, and share knowledge.

Close
Important Announcement: WELCOME to the new Schneider Electric Community! Community is now no longer part of Exchange, and is now rebranded under se.com. If you have any bookmarks and links saved, we request you to update them to ensure that you continue accessing our community from this new location. For any issues that you might encounter as part of this change, please reach out to SchneiderCommunity.Support@se.com, and the team will help to get your issues resolved.
Invite a Co-worker
Send a co-worker an invite to the Exchange portal.Just enter their email address and we’ll connect them to register. After joining, they will belong to the same company.
Send Invite Cancel
82165members
349752posts

Command Line Script not working

APC UPS for Home and Office Forum

Schneider Electric support forum for our APC offers including Home Office UPS, Surge Protectors, UTS, software and services and associated products designed to share knowledge, installation, and configuration.

Solved
hdpete_apc
Crewman
Crewman
0 Likes
2
156

Command Line Script not working

This was originally posted on APC forums on 5/18/2012


Hi,

I have a new Smart UPS 750SC which I am setting up and I have running a home server and UPS. The UPS is connected via USB to the server which is running Powerchute Business Edition.

I have set an action in the agent web interface to email me on power loss (working) and execute a command line which in turn runs a batch file to shutdown my NAS and then perform a server shutdown.

However, the email gets delivered, but the script fails to run. I have checked that both the agent and server services are set to use the System Account and that they can interact with the desktop. The contents of the terastation.cmd file is:

@start /D "C:\Program Files (x86)\Java\jre7\bin" java.exe -jar acp_commander.jar -t 192.168.1.2 -o -blink -shutdown

If I remove the @start and run the batch file, the process works perfectly.

Can anyone see what is happening?

Regards
Peter


Accepted Solutions
hdpete_apc
Crewman
Crewman
0 Likes
0
156

Re: Command Line Script not working

This was originally posted on APC forums on 5/18/2012


Yes. That's where I tried the Services configuration.

See Answer In Context

2 Replies 2
BillP
Administrator Administrator
Administrator
0 Likes
0
155

Re: Command Line Script not working

This reply was originally posted by Angela on APC forums on 5/18/2012


have you referenced this yet?

http://nam-en.apc.com/app/answers/detail/a_id/7712

hdpete_apc
Crewman
Crewman
0 Likes
0
157

Re: Command Line Script not working

This was originally posted on APC forums on 5/18/2012


Yes. That's where I tried the Services configuration.