Welcome to the new Schneider Electric Community

It's your place to connect with experts and peers, get continuous support, and share knowledge.

  • Explore the new navigation for even easier access to your community.
  • Bookmark and use our new, easy-to-remember address (community.se.com).
  • Get ready for more content and an improved experience.

Contact SchneiderCommunity.Support@se.com if you have any questions.

Close
Invite a Co-worker
Send a co-worker an invite to the Exchange portal.Just enter their email address and we’ll connect them to register. After joining, they will belong to the same company.
Send Invite Cancel
84702members
354079posts

APC (BK350) - NO POWER - Photos Attached

APC UPS for Home and Office Forum

Schneider Electric support forum for our APC offers including Home Office UPS, Surge Protectors, UTS, software and services and associated products designed to share knowledge, installation, and configuration.

Solved
nofear2007_apc
Crewman
Crewman
0 Likes
1
221

APC (BK350) - NO POWER - Photos Attached

This was originally posted on APC forums on 5/9/2010


I purchased this unit new about 4 years ago and up until a few days ago has been working great. Here is my current status...

The green light is on, the unit has been tried in several outlets, the unit has remained plugged in for over 24 hours and the battery fully charged. When plugged into and outlet OR unplugged and the yellow (battery light) is on here's what happens....no power on the back up side (the 3 plugs) but power to the surge protection side (the 3 plugs) - Power Chute is operational and shows on AC power on and at 100% w/estimated back up power of 110 mins also the self test passes every time, I tried everything from removing the battery, manually doing the self check test (holding the button in about 10 sec) also changed the sensitivity nothing I have tried will turn on the back up. Note that the circuit breaker is out about 1/2 to 3/4 of an inch, when I push in the breaker nothing happens it just goes back to the same position, I attached some pics, please let me know what I can do.

Thanks, Frank

Attachments

Accepted Solutions
nofear2007_apc
Crewman
Crewman
0 Likes
0
220

APC (BK350) - NO POWER - Photos Attached

This was originally posted on APC forums on 5/9/2010


I purchased this unit new about 4 years ago and up until a few days ago has been working great. Here is my current status...

The green light is on, the unit has been tried in several outlets, the unit has remained plugged in for over 24 hours and the battery fully charged. When plugged into and outlet OR unplugged and the yellow (battery light) is on here's what happens....no power on the back up side (the 3 plugs) but power to the surge protection side (the 3 plugs) - Power Chute is operational and shows on AC power on and at 100% w/estimated back up power of 110 mins also the self test passes every time, I tried everything from removing the battery, manually doing the self check test (holding the button in about 10 sec) also changed the sensitivity nothing I have tried will turn on the back up. Note that the circuit breaker is out about 1/2 to 3/4 of an inch, when I push in the breaker nothing happens it just goes back to the same position, I attached some pics, please let me know what I can do.

Thanks, Frank

See Answer In Context

1 Reply 1
nofear2007_apc
Crewman
Crewman
0 Likes
0
221

APC (BK350) - NO POWER - Photos Attached

This was originally posted on APC forums on 5/9/2010


I purchased this unit new about 4 years ago and up until a few days ago has been working great. Here is my current status...

The green light is on, the unit has been tried in several outlets, the unit has remained plugged in for over 24 hours and the battery fully charged. When plugged into and outlet OR unplugged and the yellow (battery light) is on here's what happens....no power on the back up side (the 3 plugs) but power to the surge protection side (the 3 plugs) - Power Chute is operational and shows on AC power on and at 100% w/estimated back up power of 110 mins also the self test passes every time, I tried everything from removing the battery, manually doing the self check test (holding the button in about 10 sec) also changed the sensitivity nothing I have tried will turn on the back up. Note that the circuit breaker is out about 1/2 to 3/4 of an inch, when I push in the breaker nothing happens it just goes back to the same position, I attached some pics, please let me know what I can do.

Thanks, Frank