Welcome to the new Schneider Electric Community

It's your place to connect with experts and peers, get continuous support, and share knowledge.

  • Explore the new navigation for even easier access to your community.
  • Bookmark and use our new, easy-to-remember address (community.se.com).
  • Get ready for more content and an improved experience.

Contact SchneiderCommunity.Support@se.com if you have any questions.

Close
Invite a Co-worker
Send a co-worker an invite to the Exchange portal.Just enter their email address and we’ll connect them to register. After joining, they will belong to the same company.
Send Invite Cancel
84611members
353910posts

License Bug on SmartConnector 2.4.36

SmartConnector Forum

Discussion of SmartConnector applications for integration of various other building management systems (BMS) into EcoStruxure Building Operation

Solved
Lydia
Lieutenant | EcoXpert Master Lieutenant | EcoXpert Master
Lieutenant | EcoXpert Master
0 Likes
4
285

License Bug on SmartConnector 2.4.36

I recently upgraded SmartConnector versions from 2.4.23 to 2.4.36. My developers' license expired a few months ago (near the time I started working on another project), so I downloaded a new SmartConnector 2.4 Runtime (Developer) license. When I tried adding the new license to SmartConnector, I was given the message that my new license was invalid because it was already expired. I looked at the license I tried to upload. The license expiration date was three months after today's date. It was correct. I rolled back the SmartConnector version from 2.4.36 to 2.4.23 and I was able to update the new license without a problem. 


Accepted Solutions
JeffBowman
Schneider Alumni (Retired)
Schneider Alumni (Retired)
0 Likes
1
275

Re: License Bug on SmartConnector 2.4.36

Hi Lydia,

 

Would you be able to try and upgrade one more time to 2.4.36? I tried to do the same thing, but I was not able to reproduce this issue.

 

There is a setting in the database that deals with anti-rollback, (so you can't install an expired license by rolling back the clock on your PC). I have seen a couple times in the past that somehow this setting gets corrupted, so it likely when you uninstalled and reinstalled 2.4.23 this issue was resolved, since you now have a new DB.

 

If you are able to see the same issue when upgrading again, I may need to do a remote debug session with you to see if I can find the source of the issue. Please let me know.

 

Best Regards,

 

-Jeff

See Answer In Context

Tags (1)
4 Replies 4
JeffBowman
Schneider Alumni (Retired)
Schneider Alumni (Retired)
0 Likes
3
282

Re: License Bug on SmartConnector 2.4.36

HI Lydia,

 

As far as I am aware, there have been no licensing changes between 2.4.23 and 2.4.36.

 

When you say you downgraded was it an uninstall and a reinstall? New database?

 

Best Regards,

 

-Jeff

Tags (1)
Lydia
Lieutenant | EcoXpert Master Lieutenant | EcoXpert Master
Lieutenant | EcoXpert Master
0 Likes
2
277

Re: License Bug on SmartConnector 2.4.36

I uninstalled the malfunctioning version and reinstalled the functioning one. I do not remember manually touching the database.

Tags (1)
JeffBowman
Schneider Alumni (Retired)
Schneider Alumni (Retired)
0 Likes
1
276

Re: License Bug on SmartConnector 2.4.36

Hi Lydia,

 

Would you be able to try and upgrade one more time to 2.4.36? I tried to do the same thing, but I was not able to reproduce this issue.

 

There is a setting in the database that deals with anti-rollback, (so you can't install an expired license by rolling back the clock on your PC). I have seen a couple times in the past that somehow this setting gets corrupted, so it likely when you uninstalled and reinstalled 2.4.23 this issue was resolved, since you now have a new DB.

 

If you are able to see the same issue when upgrading again, I may need to do a remote debug session with you to see if I can find the source of the issue. Please let me know.

 

Best Regards,

 

-Jeff

Tags (1)
Lydia
Lieutenant | EcoXpert Master Lieutenant | EcoXpert Master
Lieutenant | EcoXpert Master
0 Likes
0
263

Re: License Bug on SmartConnector 2.4.36

Reinstalling Smart Connector fixed the problem, thanks!

Tags (1)