Welcome to the new Schneider Electric Community

It's your place to connect with experts and peers, get continuous support, and share knowledge.

  • Explore the new navigation for even easier access to your community.
  • Bookmark and use our new, easy-to-remember address (community.se.com).
  • Get ready for more content and an improved experience.

Contact SchneiderCommunity.Support@se.com if you have any questions.

Close
Invite a Co-worker
Send a co-worker an invite to the Exchange portal.Just enter their email address and we’ll connect them to register. After joining, they will belong to the same company.
Send Invite Cancel
84384members
353573posts

Double Trouble: Processor Parameter of Type Double Failing When Not An Int

SmartConnector Forum

Discussion of SmartConnector applications for integration of various other building management systems (BMS) into EcoStruxure Building Operation

Solved
Lydia
Lieutenant | EcoXpert Master Lieutenant | EcoXpert Master
Lieutenant | EcoXpert Master
0 Likes
2
170

Double Trouble: Processor Parameter of Type Double Failing When Not An Int

I have a processor parameter named "Numeric Not Set Value". This parameter is of the type double, so I should be able to use numbers such as -1, 1000, 0.5, 1.6667, etc. 

 

If I set the default value in the code of my processor to a decimal number, like 1.5, the processor works as intended. If I change the default value in the Details tab of the Processor Configuration page to any decimal number other than the default value I chose in the processor code, I receive an error which states "{Name of variable} is required."

 

Is this intentional, or is this a bug? 

 

 
 

NumericNotSetCode.PNGNumericNotSetSmartConnector.PNGNumericNotSetSmartConnector2.PNG

 


Accepted Solutions
JeffBowman
Schneider Alumni (Retired)
Schneider Alumni (Retired)
0 Likes
1
168

Re: Double Trouble: Processor Parameter of Type Double Failing When Not An Int

Hi @Lydia ,

 

I believe you have found a bug, I tested it locally, and it seems it actually works as long as it is an integer value, but as soon as you give it a decimal point, it shows this error.

 

My guess is that this is a Portal bug only, so if you need to test it in the meantime, in theory you could change this value to anything you want directly in the database (in the Parameters table).

 

I will look into a fix for this, and will include it with the next Smart Connector release.

 

Best Regards,

 

-Jeff

See Answer In Context

Tags (1)
2 Replies 2
JeffBowman
Schneider Alumni (Retired)
Schneider Alumni (Retired)
0 Likes
1
169

Re: Double Trouble: Processor Parameter of Type Double Failing When Not An Int

Hi @Lydia ,

 

I believe you have found a bug, I tested it locally, and it seems it actually works as long as it is an integer value, but as soon as you give it a decimal point, it shows this error.

 

My guess is that this is a Portal bug only, so if you need to test it in the meantime, in theory you could change this value to anything you want directly in the database (in the Parameters table).

 

I will look into a fix for this, and will include it with the next Smart Connector release.

 

Best Regards,

 

-Jeff

Tags (1)
Lydia
Lieutenant | EcoXpert Master Lieutenant | EcoXpert Master
Lieutenant | EcoXpert Master
0 Likes
0
165

Re: Double Trouble: Processor Parameter of Type Double Failing When Not An Int

Thank you, Jeff.

 

Best Regards,

- Lydia

Tags (1)