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Unable to save periodic report to network drive when Vista is running as a service

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Unable to save periodic report to network drive when Vista is running as a service

Picard Product_Support
‎2018-09-06 02:28 PM

Issue

Unable to save periodic report to network drive when Vista is running as a service.

Vista Alarm: Warning logged in B0WARLOG.TXT on node XXXXXX
B0WARLOG.TXT: report >> Could not save report Reports-Report, hRes=[-2146827284]

Product Line

TAC Vista

Environment

Vista 5.x

Cause

When Vista Server (TACOS.exe) is running as a service, it is not functioning as part of the user desktop. This means that network map drives are not accessible under the aliases (J:\, M:\, S:\, etc). Vista Server is instead running under a specific user account name that must have access rights to the network drive and the report object must reference the full path to the network drive location.

Resolution

NOTE: it is recommended that the destination folder for these periodic reports be located on the local disk C;/ drive.  It can be problematic to have the destination folder located on the desktop.

  1. Open the Services MMC from Control Panel\Administrative Tools\Services.
  2. Find TACOS in the list of services. Stop it if it is running.
  3. Right click on the service and select properties. On the Log On tab check the "This Account" option and fill in a local administrator user that has access to the network location. Click Ok.
  4. Start the TACOS service.
  5. Start Vista Workstation and log in.
  6. Right click the report you are trying to save to a network drive and select properties. On the Report tab ensure that the "Save to folder:" has the full network path (ex. \\computername\directoryname). Use the browse if necessary. Click OK

The next time your periodic report runs it will properly save the report to the network location.

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