Issue
- LNS Database errors
- Corrupted LNS Database
Product Line
TAC Vista
Environment
- LNS Turbo (3.2 or later) Database
- LonMaker, NL220
Cause
There are various causes for a corrupted LNS database. Backups, disk defragmenters, older versions of LNS, PC crashes, can cause errors in the LNS database.
Resolution
Before giving up on a troublesome database and rebuilding everything from scratch, try to repair any background errors by running it through the LNS Database Validator. It can identify, and sometimes fix errors in the database, restoring functionality.
The Validator tool works in "layers". Depending on the corruption, errors may need repaired by a specific hierarchy. This means validation may need to be performed multiple times to correct remaining errors.
- Backup the LNS database. Do not proceed until a valid backup is created.
- Go to Start > Programs > Echelon LNS Utilities > LNS Database Validator
- This program only works on LNS 3.2 and later, and will not be available to LNS 3.1 PCs
- Under Network to Validate: browse to the desired LNS database
- Do not check "Repair Database" the first time. Just hit Validate.
- Make note of any errors that are found. Now check "Repair Database" and Validate again.
- Make note of any errors that have been corrected.
- Try to open and use the LNS database again.
- You may need to repeat steps 5 and 6 until all errors are corrected, or until the Validator refuses to correct the remaining errors.