Warning
Potential for Data Loss: The steps detailed in the resolution of this article may result in a loss of critical data if not performed properly. Before beginning these steps, make sure all important data is backed up in the event of data loss. If you are unsure or unfamiliar with any complex steps detailed in this article, please contact Product Support Services for assistance.
Issue
Information needed about how to change the "appuser" password used by the Report Server Agent
Product Line
EcoStruxure Building Operation
Environment
Web Reports
Cause
There is no information available on whether the Web Reports "appuser" account password can be changed and how it's done
Resolution
NOTE: Refer to the following article Report Server "appuser" clarification for additional information on the appuser
The password defined for the user in the configuration file needs to match the actual password in the operating system.
To change the password, do the following
- Stop the WebReports Agent service
- Change the password defined for the "appuser" in Windows
- Change the password defined for the "appuser" in the WebReports Agent config file:
C:\Program Files (x86)\Schneider Electric\StruxureWareReports\StruxureWare Reporting Agent\SE.WebReports.StruxureWareReportingAgent.exe.config - Restart the WebReports Agent service