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Repair or replace an obsolete part from the Network 8000 and DMS product lines

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Repair or replace an obsolete part from the Network 8000 and DMS product lines

Picard Product_Support
‎2018-09-07 02:22 AM

Issue

An obsolete part from the Network 8000 and DMS product lines has failed. Is there an option to repair and/or replace it with a refurbished unit?

Product Line

TAC IA Series

Environment

NETWORK 8000

Cause

Replacement parts for obsolete parts on the Network 8000 and DMS product lines.

Resolution

A company has been retained that can repair and/or replace several parts from both product lines.

Contact information:

  • Name: ISA
  • Phone: 1-800-430-6013
  • Web: www.isa-net.com

On the home page of their website, select "Energy" at the top of the screen and then click on "Parts". On the new screen, click on "Barber-Colman (Invensys)". On the subsequent screen, click on "Invensys". A list of available parts for both Network 8000 and DMS will result. Availability varies so it is best to contact them by phone.  For additional information, see Product Announcement PA-00164 Network 8000 Availability – REPAIR UPDATE.

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