Issue
Vista Change of State object monitoring an I/NET point value are in Alarm but not changing state or getting through to Vista Alarm queue.
Environment
- I/NET point monitoring
- Vista Alarm Queue
- Xenta Server Alarms
- I2V
Cause
Incorrect settings of the I/NET point Watch Status, and Vista Change of State object.
Resolution
There are a few settings unique to I/NET points that have to be properly modified in order for an Alarm to be passed into the Vista Workstation Alarm queue.
- In Workstation, navigate from your Xenta Server to the input/output point generating the Alarm in I/NET.
- Right click on the point and select Properties.
- Set the Watch Setting to "Alarm".
- Navigate to the Change of State object that is referencing the I/NET point to create the alarm.
- Right click on the Change of State object and select properties.
- Set the Alarm triggering text field to the value expected in alarm condition, i.e. 1.
- Set the Alarm resetting text field to the value expected in back to normal, i.e. 0.
- Toggle the I/NET point manually into alarm and return to normal once to verify the alarm is in the queue.