Welcome to the new Schneider Electric Community

It's your place to connect with experts and peers, get continuous support, and share knowledge.

  • Explore the new navigation for even easier access to your community.
  • Bookmark and use our new, easy-to-remember address (community.se.com).
  • Get ready for more content and an improved experience.

Contact SchneiderCommunity.Support@se.com if you have any questions.

Invite a Co-worker
Send a co-worker an invite to the Exchange portal.Just enter their email address and we’ll connect them to register. After joining, they will belong to the same company.
Send Invite Cancel

[Imported] ViewX Inactivity Timeout Settings

EcoStruxure Geo SCADA Expert Forum

Find out how SCADA systems and networks, like EcoStruxure Geo SCADA Expert, help industrial organizations maintaining efficiency, processing data for smarter decision making with IoT, RTU and PLC devices.

Janeway Janeway

[Imported] ViewX Inactivity Timeout Settings

>>Message imported from previous forum - Category:ClearSCADA Software<<
User: florian, originally posted: 2018-10-25 17:35:55 Id:255
This is a re-posting from the obsoleted (October 2018) "Schneider Electric Telemetry & SCADA" forum.


**_The ViewX Client on a Server seems to ignore the Inactivity timeout setting of 0minutes and falls back to the default Inactivity timeout of 15Minutes._**

**_Is there way of setting up Inactivity timeout such that it never times out without having to set it to a large timeout figure?_**

**_Also, is it possible to set up ViewX so that when it logs out a user, it defaults to the Guest account instead of the ViewX Login Screen?_**


On the server client and the 15 minutes. Are you using the Super User account? The newer versions, I think 2017, the Super User account is not meant to be used on a regular basis. Essentially, it is only meant to be used to setup a group of admins, then the Super User account should be shut off. That was done for security purposes.

More recently I have been getting into various security and logon scenarios. There is a lot that can effect what happens when a user logs out. The Guest account needs to be turned on, the Guest group under security properties needs to have access to the root group where the bulk of your user viewable mimics are, etc. Each user account has a Inactivity Logout at the bottom of the security tab under the properties of the user. Try setting them to 0 if they are not already.


As mentioned by Shawn, the value of 0 is generally a bit special and actually means don't even do the action that it applies to. So don't use the inactivity timeout.

Also as mentioned by Shawn, if you are using the Superuser account then it will ALWAYS timeout on inactivity, and there is no getting around that. There are also a number of other restrictions on the Superuser account that mean it SHOULD NOT be used for normal login activities.


Just to clarify. Logged our is when you are logged in as Guest; the only way you can log in as Guest is to log out.


I often use Inactivity Timeout = 0, and it works properly, at least for ClearSCADA 2015 R2. There is no logout after any period of inactivity. Of course it works only for "usual" users, not for Superuser.

I set 0 as shown on attached screenshot (all checkboxes are cleared). May be it has the meaning. In any case it will be better to restart ClearSCADA database after settings change.

![]((see attachments below) ym/4ps4dggxo7vh.jpg "")


**_Thanks all. Inactivity Timeout of 0 works on all other accounts other than Superuser._**

**_[at]Adam, If i set an inactivity timeout and the time expires, ViewX defaults back to the log on screen. Is it possible for ViewX to simply log in as Guest and not default to the log on screen?_**


Not currently possible in the current ViewX client. The old client used to work that way (not that this comment helps).

Interestingly there have been a few discussions on this recently.

If you want this make sure you log this with support so the product team understands how many customers would like to see this, this has an impact on what gets done.


This is actually an option on the latest versions, check the Logout on Inactivity box in ViewX options and it will go straight to guest user so long as there are no pending changes.


**_Thanks for the Suggestion Jesse. I am using 2017 (Initial Release). Can't see the option. If you could send a screenshot that will be great!_**


It is at the very bottom of the General tab.
I have it on my 2017 version but it is the Dec 2017 build


Yep as Geoff says, it was implemented for CS2017R2 and back ported to CS2017 in one of the Updates.

![]((see attachments below) 66/3ijoeqaah4rt.jpg "")


I like being wrong sometimes 🙂

Attached file: (editor/ym/4ps4dggxo7vh.jpg), ScreenShot 2018-07-11 153241.jpg File size: 33836

Attached file: (editor/66/3ijoeqaah4rt.jpg), Capture5.JPG File size: 106530