Issue
When importing Security Expert controllers into Security Expert Server using the Data Sync Service, the Register As Reader Expander address field is different from the value in the CSV file. The address field is incremented by 1.
Product Line
EcoStruxure Security Expert
Environment
- Security Expert Server
- Security Expert Data Sync Service
Cause
Register As Reader Expander values in the Security Expert SQL database are stored as integers where indexing starts at 0, whereas in the Security Expert Client the same values are displayed as integers starting at 1. The Data Sync Service updates the database values directly, which is why the values differ between the CSV file and the user interface.
Resolution
In the CSV import file, decrement values in the Register As Reader Expander column by 1. For example: If the address in the user interface is '1', the value in the CSV file should be changed to '0'. See screenshot from Data Sync Service (left) and Security Expert Client (right) below.