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WorkStation HTTPS connection and cloud connectivity fail if TLS V1.3 is enabled in a non-supported Windows

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WorkStation HTTPS connection and cloud connectivity fail if TLS V1.3 is enabled in a non-supported Windows

Spock Mahmoud_Sayed Spock
‎2024-10-16 09:10 AM

on ‎2024-10-16 09:10 AM

Issue

WorkStation can't connect via secure communication (HTTPS) to EBO server, although it can connect via non-secure communication (HTTP). Cloud connectivity also fails. WebStation can still connect via HTTPS.

Product Line

EcoStruxure Building Operation

Environment

  • Building Operation Enterprise Server
  • Building Operation Enterprise Central
  • Building Operation WorkStation

Cause

TLS V1.3 is supported in Windows 11 and Windows Server 2022 or later. Enabling it in earlier Windows versions is not support it can lead to problems, as explained in Protocols in TLS/SSL (Schannel SSP) - Win32 apps | Microsoft Learn

Resolution

Do not enable TLS V1.3, If the installed Windows version doesn't support it (Windows 10 and Windows Server 2019 or earlier), or disable it if it is already enabled by following the below steps: 

    1. Open Windows Registry Editor, by writing "regedit" in Start menu. 
    2. Goto registry path "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.3\Client"
    3. Make sure that "Enabled" is set 0, and "DisabledByDefault" is set to 1, this will disable TLS V1.3 for clients. Mahmoud_Sayed_0-1729080548182.png
    4. Restart WorkStation.

 

For more information, refer to: Transport Layer Security (TLS) registry settings | Microsoft Learn

Warning! Improper use of regedit may damage PC’s operation.

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