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WorkPlace Tech "Application Menu" and some "Tools Menu" entries are missing or grayed out.

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WorkPlace Tech "Application Menu" and some "Tools Menu" entries are missing or grayed out.

Picard Product_Support
‎2018-09-06 02:37 PM

Issue

WorkPlace Tech "Application Menu" and some "Tools Menu" entries are missing or grayed out.

When attempting to run the WorkPlace Tech Tool,

  1. Application Menu missing or grayed out.
  2. All WorkPlace Tech Tool related entries in the Tools menu are grayed out or missing.  
  3. Project Toolbars are not displayed. 

Environment

  • WorkPlace Tech Tool 4.0.x, 5.7.0 - 5.7.3
  • Microsoft Visio 2002, Visio 2003 or Visio 2007
  • Microsoft Windows XPsp2, XPsp3, Vista or Windows 7

Cause

Various causes beyond the scope of this article.

Resolution

There are several different reasons why these entries are grayed out or missing and therefore not selectable. There are two parts to the procedure to correct the problem, disabling COM addins and deleting the Visio directory cache. The exact procedure depends on the version of Visio and the version of Windows being used.

WorkPlace Tech with Visio 2007

  1. Open Visio 2007
  2. Open the Tools Pull down.
  3. Select the Options.
  4. Select the Trust Center
  5. Select Add-ins.
  6. Verify that the box "Disable all Application Add-ins" is NOT checked.
  7. At the bottom of the screen, COM Add-ins is the default selection. Press GO.
  8. In the COM Add-ins box displayed, un-check the box for all third party add-ins. Click OK to apply.
  9. Close Visio 2007
  10. Delete the Visio Directory Cache file, as follows, depending on the version of Windows.
    1. If running Windows Vista, delete the file c:\Users\< username >\AppData\Local\Microsoft\Visio\content12.dat
    2. If running Windows XP, delete the file c:\Documents and Settings\< username >\Local Settings\Application Data\Microsoft\Visio\content12.dat
  11. Open Visio 2007 and wait for the "Getting Started with Microsoft Visio" window to be displayed.
  12. Close Visio 2007.
  13. Open WorkPlace Tech, all menu items should be there.
  14. If some or all of the WorkPlace Tech Tool menu entries are still grayed out, repeat these steps, disabling all COM addins.

Workplace Tech with Visio 2003

  1. Open Visio 2003
  2. Open the Tools menu.
  3. Select Options, then Security.
  4. Un-check the box for COM add-ins.
  5. Check the box for "Enable Microsoft Visual Basic for Applications".
  6. Check the box for "Enable Automation events"
  7. Click OK to apply.
  8. Close Visio 2003.
  9. Delete the Visio Directory Cache file, as follows, depending on the version of Windows.
    1. If running Windows Vista, delete the file c:\Users\< username >\AppData\Local\Microsoft\Visio\content.dat
    2. If running Windows XP, delete the file c:\Documents and Settings\< username >\Local Settings\Application Data\Microsoft\Visio\content.dat
  10. Open Visio 2003 and wait for the "Choose Drawing Type" window to be displayed.
  11. Close Visio 2003
  12. Open WPT, all menu items should be there.

Workplace Tech with Visio 2002

  1. Open Visio 2002
  2. Open the Tools menu.
  3. Select Options, then Advanced.
  4. Un-check the box for COM add-ins.
  5. Check the box for "Enable Microsoft Visual Basic for Applications".
  6. Check the box for "Enable Automation events"
  7. Click OK to apply.
  8. Close Visio 2002.
  9. Delete the Visio Directory Cache file, as follows, depending on the version of Windows.
    1. If running Windows Vista, delete the file c:\Users\< username >\AppData\Local\Microsoft\Visio\VISIO.BIN
    2. If running Windows XP, delete the file c:\Documents and Settings\< username >\Local Settings\Application Data\Microsoft\Visio\VISIO.BIN
  10. Open Visio 2002 and wait while Visio updates its directory cache. The process is complete when the "Choose Drawing Type" window is displayed.
  11. Close Visio 2002
  12. Open WPT, all menu items should be there. 
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