Issue
When update Vista database through System Plug-in got error message saying “Update Vista database failed”.
Open Workstation, in the alarm window, there is error message saying “unable to request license”.
Environment
CIRCON Network Integrator or other LNS network builder, customer license file
Vista 5
Cause
Vista cannot recognize the LNS server license. This happens when you use some LNS network builder besides LonMaker or NL-220, and you are using a purchased license file instead of a demo license file or an engineering dongle.
Resolution
If you get the “Update Vista database failed” error message in system plug in. Make sure you have done the group binding or redo the group binding.
If the issue still exists, check the system plug-in output window and see if there is any error message before the “update vista database failed” message. If not, open TAC Vista Workstation and check the alarm window. If you see the error message says “unable to request license”, this means TAC Vista server cannot file the LNS server license.
The TAC Vista demo license or an engineering dongle has a full version of all licenses which includes the LNS server license. You will see a line below in your demo license file:
FEATURE Vista.Server.LNS taclic 5.1 31-oct-2010 uncounted HOSTID=DEMO
However, the purchased customer license file does not have “Vista.Server.LNS” license included.
The solution to this issue is either rebuilding the LNS network in LonMaker or NL-220, or purchasing an engineering dongle or using the demo license file.