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Vista Trend Log Failure: Failed to write log values to log database.

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Vista Trend Log Failure: Failed to write log values to log database.

Picard Product_Support
‎2018-09-07 07:16 AM

Issue

Trend log creation is successful, but no values are recorded in the Vista SQL database. Error message “Failed to write values to log database” is visible in Vista Workstation alarm window and review of the b0warlog.txt in the $log folder of the Vista database reports errors:

TLogHandler :: ObjectInitEnd: Failed to setup event log queue directory (hr=-2147024773)

TLogXenta :: ServiceExecuted: Log (Path to Trend Log) not successfully read. Error: -2147024893

Environment

Vista 4.3.0 - 4.5.0, 5.x.x

Cause

Corruption in the Vista database directory $queues folder causes disruption in recording of trend log values.

A file with the name of insertlogvalues exists in the $queues directory when Vista Server is expecting a directory to exist with that name. Attempts to write queue files to the \$queues\insertlogvalues\ directory fails with a ERROR_PATH_NOT_FOUND error ( -2147024893). When Vista Server starts it tries to create the directory, but due to the presence of the file with the same name the process fails with a ERROR_INVALID_NAME error (-2147024773).

Resolution

  1. Shut down Vista Workstation and Vista Server.
  2. Start Vista Server Setup from Start Menu\All Programs\Schneider Electric\TAC Vista Server 5.1.x\Server  Setup. For Vista version lower then Vista 5.1.4: Start Menu\All Programs\TAC\TAC Vista Server x.x.x\Server Setup.
  3. Click the Vista Database tab to view the Vista database directory:Vista database directory setting
  4. Open a Windows Explorer and browse to the Vista database directory.
  5. Open the $queues directory.
  6. Delete the contents of directory.
  7. Start Vista Server.

Trend Log operation should now be restored.

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