Issue
The Vendor daemon fails to start on the License Server.
Product Line
EcoStruxure Building Operation
Environment
Ecostruxure Building Operation License Server
Warning
Potential for Data Loss: The steps detailed in the resolution of this article may result in a loss of critical data if not performed properly. Before beginning these steps, make sure all important data is backed up in the event of data loss. If you are unsure or unfamiliar with any complex steps detailed in this article, please contact Product Support for assistance.
Cause
The issue occurs due to special characters (e.g., ô, ã, non-breaking space) in the Computer Name of the operating system hosting the License Server. - see screen shot below.
- This can be observed in the FlexNet Publisher management page (localhost:8888).
- The taclic.log file may contain entries such as:
10:11:55 (taclic) Server started on Test-aã for: B 10:11:55 (taclic) client.station client.station graphdb.base 10:11:55 (taclic) server.cloud.customer server.enterprise.base server.es.as 10:12:08 (taclic) EXTERNAL FILTERS are OFF 10:12:11 (taclic) Unknown Hostname: Test-aã
Resolution
To resolve the issue:
- Edit the Computer Name of the host machine.
- Remove any special characters (e.g., accented letters, non-breaking spaces).
- Restart the License Server after making the changes.