Issue
When using Sigma on a PC with firewall enabled, communication doesn't work.
Product Line
Satchwell Sigma
Environment
- Sigma Server
- Sigma Client
- Firewall
Cause
In most cases Sigma is installed on a separate network and is not connected to any outside sources. The firewall is therefore turned off in some cases. Where Sigma is installed on an existing network or a corporate network it is usual for the firewall to be turned on. If this is the case then rules will need to be created to allow correct operation of Sigma.
Resolution
On a remote Sigma Client the first time you run SigmaClient there should be a popup to allow an exception to be created for SigmaClient. When asked select yes to this.
Next task is to create rules to allow comms through the firewall. The next task is done on the remote client PC's and on the server PC.
- Open Windows Firewall configuration: Control Panel\All Control Panel Items\Windows Firewall
- Click on "Advanced settings" to the left
- Click on "Inbound Rules" and click on "New Rule..."
- From the selection choose Port, click Next
From this point it is needed to do the rest once for UDP and once for TCP. The example will show UDP 49152, and needs to be repeated for TCP 8080 and TCP 3614. - Chose UDP and enter 49152. Click Next.
- Select "Allow the connection". Click Next.
- Select the applicable networks. Click Next.
- Type in a name for the rule. Click Finish.
Go to step 5 and repeat for ports TCP 8080 and TCP 3614