Issue
Platform connection using TLS fails. Standard HTTP connection of port 3011 successful.
Product Line
TAC IA Series.
Environment
I/A Series Enterprise Server
Cause
TLS platform connection fails immediately and throws an exception in Workbench. Note that the Niagara Daemon is running and a non-TLS HTTP connection is successful.
No station is currently running on the PC. All stations are stopped.
Example exception-
SEVERE [08:45:58 02-Sep-20 CDT][wb.shell] Error connecting to platform daemon at localhost:
GET /platformInfo
javax.baja.naming.UnresolvedException: platformssl:
Resolution
A possible cause is a zero-byte file size bog file in the Daemon Home 'stations' folder.
- Check all of the station folders in Daemon Home, searching for any bog file that is zero bytes in size.
- Look for 'Config.bog.lock' files as one could be orphaned when a station running in the Niagara daemon were to stop unexpectedly, such as the system reboots suddenly or the PC is powered down.
- Remove all files that are zero bytes in size. Remove any 'Config.bog.lock' files.
- Test the TLS connection for a successful connection.