Issue
Unable to connect to a Niagara R2 UNC-520. The IP address was incorrectly set. How can the IP address be found and changed if there's no access via the Ethernet port?
Environment
UNC-520 or UNC-410
Cause
Incorrect entry of the IP Address or subnet mask can cause the UNC appear unresponsive to the WorkPlace Pro software.
Resolution
There are two methods available to determine the IP and subnet mask entered into the UNC.
The first method requires having access to the computer used to change the IP address. Look at the file "ipchanges.txt" located in the "\Niagara\r2.301.522\nre\user" folder. It will contain the date, time, user name, original IP, new IP, and controller name (i.e. 9:54 16-Dec-2008 CST: tac 10.159.34.123 -> 10.1.146.128 on J404-29764).
The second method requires the use of a terminal program, a UNCC-405 to adapt RS232 to RJ45, and a CBL-RJ45 cable (a standard ethernet cable no longer than seven feet will do). The HyperTerminal program is used to directly connect to a UNC-520 to verify and to make changes to its IP address in order to make it accessible. HyperTerminal makes it possible to view the UNC's configuration and execute commands. The steps needed to directly connect to a UNC-520 using HyperTerminal are listed in chapter 2 of the Niagara Networking & Connectivity Guide. After connecting to the UNC, use the procedure "Determining an IP address of a JACE-4/5" in the section "Determining Network Settings" of Chapter 3 of the same manual to display or change the IP address or subnet mask. Failure to enter the subnet mask properly can prevent the UNC from being seen by WorkPlace Pro.