Issue
The "Transactions Individual" report in Seven Reports does not sort the transactions by Date and Time.
Product Line
TAC INET
Environment
- I/NET Seven
- Seven Reports
Cause
The "Transactions Individual" report is not sorted by Date and Time
Resolution
The "Transactions Individual" report is not sorted by Date and Time for a reason. I was determined by TAC, that the customer needs to design the method by which they want this report to be presented.
This White Paper will define how to go about setting the Sort process by the Date and Time Option.
- Start Seven Reports and open the “Transactions Individuals” report
- Once the report is fully developed on the screen. Choose the “Design” tab
- In any of the blank white area do a “Right Mouse” Click
- In the “Popup” window selects the “Report” Option
- In the next “Popup” window selects the “Sort Records…” Option
- In the next “Popup” window you need scroll the left window unit you find the “RptEvents.DateTime” Option. Then Select the “Add” button the place the “RptEvent.DateTime” Option in the right window.
- After you do Step 6 this is what you will see in the right window
- You need to highlight the “RptEvent.DateTime” function.
- Then select either “Ascending” or “Descending” sort order.
- In the “Ascending Mode” the “Oldest Date” is on the top of the list and the most “Recent Date” is at the bottom of the list.
- In the “Descending Mode” the most “Recent Date” is on the top of the list and the “Oldest Date” is at the bottom of the list.
- I selected the “Descending” Mode as the way I wanted to sort the Date and Times. You also need to select the “OK” button to finish the setup process.
- You need to close out of this report. Select “Yes” button to save the changes you made in the “Canned” report. Remember to rename you newly created report to something other than the Original “Canned” report name.