Issue
The Niagara G3 platform daemon will not run using an administrator account in Windows.
Product Line
TAC IA Series
Environment
Niagara G3
Cause
Possible causes:
- The niagara service is not started
- IIS is running on the computer
- Port 3011 is blocked
- Authentication
Resolution
There are a number of possible causes:
- The niagara service is not started. Run Platform Daemon (Start > Programs > Vykon AX Supervisor > Install Platform Daemon)
- IIS is running on the computer. Disable IIS in Control Panel > Administrative Tools > Services
- Port 3011 is blocked. Ensure there are no firewall, antivirus, or remote access software blocking port 3011
- There are two types of platform authentication:
- Basic platform authentication (the default for a Windows-based host) provides integration with existing Windows installations, and provides two levels of platform access, which are determined by a user’s group membership(s). The levels of platform access are:
- User - Platform access at this level allows full use of most Workbench platform views. This includes the ability to install or delete licenses and stations (including the one running), also to install, reinstall, or upgrade the platform dist file and/or modules, and to start, re-start, or stop a station.
- Admin - Full access. This includes all user-level platform operations, plus the ability to configure host TCP/IP settings and dial-up configuration, change platform authentication, change platform daemon HTTP port, change host date/time settings, use the File Transfer Client, and reboot the host.
- Digest platform authentication provides only full level platform login access, using a single platform user account. With Digest platform authentication, there is no linkage between Windows OS user accounts and the platform administrator.
- Basic platform authentication (the default for a Windows-based host) provides integration with existing Windows installations, and provides two levels of platform access, which are determined by a user’s group membership(s). The levels of platform access are:
If Basic authentication does not work, then Digest authentication must be used. To enable digest authentication, do the following:
- Using Notepad or WordPad, open the daemon.properties file located in C:\niagara\[release]\daemon folder
- Add the following lines to the end of the file: installFlag=doc authtype=digest/file user=[username] (where you select the username) password=[password] (where you select the password) stationIsAdmin=true
- Save, then close the file
- Restart the platform daemon (Start > Programs > Vykon AX Supervisor > Install Platform Daemon)
- Launch Workbench AX, then open the platform using the username and password you provided in step 2.
Consult the Niagara AX Platform Guide for more information.