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System License Information shows zero (0) Activated Count

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System License Information shows zero (0) Activated Count

Guinan RobertAndriolo Guinan
‎2024-03-27 07:13 PM

Warning

Potential for Data Loss: The steps detailed in the resolution of this article may result in a loss of critical data if not performed properly. Before beginning these steps, make sure all important data is backed up in the event of data loss. If you are unsure or unfamiliar with any complex steps detailed in this article, please contact Product Support for assistance.


Issue

When viewing License Information, the Activated count still shows 0 for all features.

Product Line

EcoStruxure Building Operation

Environment

  • Building Operation License Administrator
  • Building Operation License Server

Cause

There are multiple causes for this, as we are aware:

  • Running Demo license
  • License Server not running / uninstalled.  It is possible to activate licenses and then uninstall the License Server, and licenses will still be active and available to EBO components.  
  • Firewall setting

Recently, we have located an issue where multiple paths exist for the License Server in the Windows Registry. The specifics of how this occurs is still unknown, but it has been seen on a few installations.  

Resolution

Before starting, remove the demo license and restart the license server.  The systems, that is, the Enterprise Central/Server, will continue to run until the servers are restarted.   This will be necessary after completing the registry reset. 

 

SBO License Server Reset Has been updated to check the known locations of the registry and provide the ability to make these entries the same as those entered in the License Administrator

RobertAndriolo_0-1711591363679.png

 

 

 A pop-up will appear during the initial running of the Reset Tool to indicate this, as shown below.

RobertAndriolo_1-1711591528626.png

 

If the tool is unavailable or you wish to check this manually, then a Windows Registry search for the key TACLIC_LICENSE_FILE and its data should show its value and indicate the different (or the same) paths.

TACLIC_LICENSE_FILE.png

Updating the TACLIC_LICENSE_FILE data to match the License Server path shown in the License Administrator should resolve the issues.  

 

SBO License Setup

This registry check is also included in the SBO License Setup tool.  In this instance, it automatically details the changes.  After selecting OK (in the screenshot below), you'll have the option to Apply (or cancel) any of the changes applied by the tool.

 
RobertAndriolo_0-1712017099258.png
 

 

 

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