Issue
Sigma Server crashes and the hard drive has filled with archived Alarm Logs all of which are of the same time.
Environment
Sigma
Cause
Sigma Server has crashed. The hard drive has filled with alarm logs with approximately the same file date.
When Sigma is re-started, the Alarm Fail Safe window is filled with "Logging Database is 100% full" "Unable to archive"
Resolution
What happens:
When the Logging Database becomes full, it is normally automatically archived.
If the c:\sigma\data\archivedlogs folder is not present then the Logging Database cannot be archived, Sigma will continuously retry to archive the database and fails continuously, each time a System Message is raised, the Alarm Log Database is filled, the Alarm Log is then archived, and the process is repeated.
To resolve:
The 3 folders are created when Sigma is installed. The folders may have been removed or deleted. Re-create the following folders under c:\sigma\data
- ArchivedAlarms
- ArchivedLogs
- ArchivedTransactions
To test:
Create an Action and Schedule to archive the log. Let the time pass, and check the ArchivedLogs folder and the file Sigma0nnnn.dbs is present. If successful, either remove the daily schedule or it can remain.