Warning
Potential for Data Loss: The steps detailed in the resolution of this article may result in a loss of critical data if not performed properly. Before beginning these steps, make sure all important data is backed up in the event of data loss. If you are unsure or unfamiliar with any complex steps detailed in this article, please contact Product Support for assistance.
Issue
DSS error occurs while importing users into Security Expert
Product Line
EcoStruxure Security Expert
Environment
- Continuum Transition Tool
- I/NET Transition Tool
- Data Sync Service
Cause
The Data Sync Service settings file contains a mapping for a credential named “User ID” but cannot find the User ID credential type. The User ID credential was not created before starting the Data Sync Service.
It is important to determine if the site is using user PINs and whether they are all unique before selecting the following option in the transition tools.
By default, SX does not allow duplicate PINs. A unique PIN is a requirement for signing into intrusion keypads with only a PIN number.
Resolution
Option 1: The site does not have user PINs in the legacy database or PINs are unique.
- Stop the data sync and transition services
- Uncheck the 'Allow PIN Duplication' option
- Click the 'Create Data Sync Service Settings File' button below
- Delete the export history of Users
- Start both Data Sync and Continuum Database Transitions services. (All users will get exported again)
Option 2: The site uses PIN numbers and there may be duplicates.
- Keep the “Allow PIN Duplication” option checked
- In Security Expert, Go to Global | Sites| Site Defaults Tab
- Scroll down and expand the Site security enhancement section
- Enable the top 3 checkboxes (Require dual credential...; Auto Populate User ID... and Allow PIN duplication)
- Click Save.