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Scheduled event reports exported to PDF are not using the local systems date time format

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Scheduled event reports exported to PDF are not using the local systems date time format

Kirk AdamSteele Kirk
‎2024-03-12 04:41 PM

on ‎2024-03-12 04:41 PM

Issue

Scheduled event reports exported to PDF are using the US date time format not the local systems date time format.

Report settingsReport settings

 

In the below example the Windows system, and Security Expert, were both setup for Australia regional settings with a date format of dd/mm/yyyy. The automatic scheduled reports exported to PDF were showing the US date format mm/dd/yyyy.

Report export beforeReport export before

 

Product Line

EcoStruxure Security Expert

Environment

Security Expert event reports

Cause

The local Windows system date settings for Welcome screen and New user accounts are incorrect.

Resolution

  1. In Windows navigate to Control Panel\Region
  2. Click on Change date, time, or number formats. A new window (Region) will pop up.
  3. Click the Administrative tab
  4. Click Copy settings...
  5. Enable the following options if not enabled already. Under Copy your current settings to tick Welcome screen and system accounts and New user accounts as shown in the image below. This will copy the Current users format over to the Welcome screen and New user accounts sections.Date format settingsDate format settings
  6. After making the above changes the PDF reports generated now show the correct date format of dd/mm/yyyy.Report export afterReport export after
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  • EcoStruxure Security Expert
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