Warning
Potential for Data Loss: The steps detailed in the resolution of this article may result in a loss of critical data if not performed properly. Before beginning these steps, make sure all important data is backed up in the event of data loss. If you are unsure or unfamiliar with any complex steps detailed in this article, please contact Product Support for assistance.
Issue
It may be necessary to replace the Security Expert Server and/or the Security Expert Software
Product Line
EcoStruxure Security Expert
Environment
Security Expert
Cause
In case of upgrade, software issues or PC/Server hardware failure replacing the Security Expert Server may be needed
Resolution
1. Hardware Reset
If the server footprint changes, for example, the previous server’s hard drive or motherboard died, then a hardware reset will be required before the license can be used on the new server. Contact Schneider Electric Product Support to tell them that your server hardware profile will be changing and a hardware reset is needed.
2. Stop the Security Expert services
Right-click on the service and select Stop
Note: While the services are stopped, the controllers will save incoming events (up to 50,000 per controller). Once that limit is reached, the events are First in First out.
3. Back up the SecurityExpert and SecurityExpertEvents databases
If the database is encrypted, export the encryption certificates. See the Security Expert Installation Manual for specific instructions on backing up and restoring databases and encryption certificates.
https://ecoxpert.se.com/search?documentUUID=71d622e3-2fc1-477a-b08a-5b37ac4b2756&title=SX-SRVR%20Sec...
4. Uninstall Security Expert from the old server
From Windows Programs and Features, Right-click Security Expert> Uninstall
Once the Uninstall is complete, Manually Restart the Server/PC
5. Disconnect the old server from the network.
Connect the new server with the same IP address and/or hostname. If the IP address or hostname of the server changes, update the event server settings in the controllers via the controller’s web page to match the new server.
6. Install Security Expert on the new server and activate the license
Ensure that the new Security Expert installation is the same version or higher.
7. Stop the Security Expert services
Restore the encryption certificates and databases to the new SQL Server instance.
8. Updating the Database
If you are restoring a database from an older version to a later version, uninstall and reinstall Security Expert to upgrade the database.
9. Start the Security Expert Data Service
10. Update the Download Server
In Security Expert, navigate to Global | Download server and update the Computer name to match the new Server name.
11. Update the Event Server
Computer name in Global | Event server
12. Restart the Security Expert Event Service
You should start receiving events from controllers
13. Start the Security Expert Download Service