Issue
During or immediately after a firmware upgrade, the RP-C controller may experience corruption of the STM32 processor's flash memory. This results in the controller misreporting its model type and becoming non-functional.
Affected RP-C controllers may exhibit the following:
- Incorrect controller model appears during BACnet discovery or in the device report.
- Controller defaults to RP-C-16A-F-230V when STM32 is unresponsive.
- No communication between STM32 and main processor (LCES).
- Controller reset button has no effect (no LED blink sequence).
- Even if the actual model is RP-C-16A-F-230V, it will not operate correctly if STM32 is corrupted.
- Lack of response to the reset button is a key indicator of STM32 corruption.
Product Line
EcoStruxure Building Operation
Environment
- Room Controller (RPC)
Warning
Potential for Data Loss: The steps detailed in the resolution of this article may result in a loss of critical data if not performed properly. Before beginning these steps, make sure all important data is backed up in the event of data loss. If you are unsure or unfamiliar with any complex steps detailed in this article, please contact Product Support for assistance.
Cause
STM32 flash corruption is caused by interruptions during firmware activation, such as:
- Power cycling the controller before activation completes.
- Network disruptions during upgrade.
- Premature assumption that upgrade is complete based on “100%” progress bar.
Resolution
To prevent the issue, perform the following:
- Do not disturb controller operation during firmware activation.
-
Ensure the following indicators are met before removing power:
-
Firmware revision is updated in the “Firmware revision” column.
-
“Upgrade status” shows Operational.
-
Controller is Online (not just showing 100% progress).
-
If STM32 corruption has occurred, follow these steps to restore the RP-C controller:
- Ensure prerequisites for your laptop:
- Enterprise Server with Demo License running 5.0.2.109 or higher
- EBO Workstation compatible with Enterprise Server version
- instructions are for DHCP network that laptop and controller are connected. Adapt for direct connection using Auto IP, if needed.
- Multiple SpaceLogic firmwares, as needed to use one different from the version the controller is currently running
- Launch EBO Workstation and log into Enterprise Server.
- Connect RPC to network via Ethernet.
- Apply 24VAC power to RPC.
- Open Device Discovery and initiate BACnet discovery using Discover All button.
- If RPC is not discovered, cycle power and retry discovery.
- Once discovered (likely as RP-C-16A-F-230V), host it to the ES IP network.
- Ensure ES has a different firmware version than the one currently on RPC.
- Go to Firmware Upgrade screen:
- Select a different firmware version.
- Choose Activate Immediately.
- Click OK to start upgrade.
- Wait for the status to change:
- “Download firmware in progress” → “Activate firmware scheduled” → “Activate firmware in progress”.
- RPC will go offline in 1–3 minutes.
- Wait 1 minute, then power cycle RPC (off for 5 seconds, then on).
- Wait another minute, then repeat power cycle.
- Within 10–30 seconds, Status LED flashes Red & Green (STM32 reprogramming is being performed).
- After ~1:15 minutes, LED flashes White & Green, then toggles Red & Blue (Bluetooth FW upgrade is being performed).
- There is an expected white and green flash of LED where the final LED state is Solid Green.
- Rediscover RPC in EBO.
- The controller should now report the correct model and be fully operational.