Issue
R2, UNC-520-2 is Displaying “Authentication mismatch” error message for a MNL-800 controller. How can this error be corrected?
Environment
R2, UNC-520
Cause
An “Authentication mismatch” error means that the authentication set in the in the LonWorksService does not match what is set in the MNL-800’s shadow object. One is set to “True” and the other is set to “False”. They should both be the same. Authentication is rarely used due to the high overhead associated with its use, so we normally recommend it not be used. Because of this, “Authenticate” should be set to “False” in the properties of both the LonWorksService and MNL-800 shadow object.
This error message applies to the MNL shadow objects as well.
Resolution
To verify if Authenticate is set to true in the property of the LonWorksService:
- Open the Properties of the LonWorksService and click on the Netmgmt tab. The Authenticate property may be set to “True” and grayed out.
To verify if Authenticate is set to true in the property of the DynamicDevice:
- Open the Properties of the DynamicDevice shadow object and click on the Engineering. The Authenticate property may be set to “True” and grayed out.
To verify if Authenticate is set to true in the property a MNL controller:
- Open the Properties of the MNL shadow object and click on the General tab and Engineering tab. The Authenticate property may be set to “True” and grayed out.
Steps to set “Authenticate” to “False”:
1. Disable Authentication using Command from the LonWorksService Property view
1. In WorkPlace Pro (WPP), open the station LonWorksService
2. Highlight the shadow objects that needs to be changed to “True” (or simply highlight all of them)
3. Select “Commands” from the WPP menu at top of page
4. Select “disAuth” from dropdown menu and select “Yes”
Note: An error may be displayed stating that the action failed even though it was successful.
2. Recommission each Lon device (if it fails to commission, reset the device then try again)
3. Rebind all affected bindings