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Queue Full Exception in Niagara

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Queue Full Exception in Niagara

Picard David_Purser Picard
‎2025-08-25 11:21 AM

on ‎2025-08-25 11:21 AM

Issue

Encounter Queue Full Exception in context of "Error writing BACnet point"

Product Line

EcoStruxure Building Operation, TAC IA Series

Environment

  • I/A Series N4 Jace 8000
  • I/A Series N4 Jace 9000
  • Niagara Station running as SoftJace or 3rd Party Jace

Cause

If you notice queue overflow messages in the station dialog, it is essential to know which queue is overflowing. There are many different communications mechanisms in BACnet, and they use different queues.

Resolution

The canonical reference article is located on Niagara Community: BACnet Tuning Suggestions

I have excerpted the following as a Rule of Thumb for the recommended starting configuration:

  1. Configure your tuning policies so that write-on-start is not enabled on some of the points - otherwise, the JACE may start with a to-do list that is larger than the queue can handle.
  2. The recommended configuration from Tridium is to set BACnet WriteWorker queues to 1.5 times the number of writable points. However, as initial configuration, Product Support has found these values to perform better than the defaults, so change the following values from 1000 to 3000.
    1. View the BacnetNetwork Property Sheet
    2. Expand Bacnet Comm
    3. Expand BACnet Comm -> Server -> Worker and Confirmed Worker
    4. Expand BACnet Comm -> Transport
    5. Change the various Queue Sizes from 1000 to 3000.
    6. Please consult PSS if a change to a value higher than 3000, as that has been found to adversely affect performance. QueueSizes_Steps.png
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  • TAC IA Series
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