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No license after reboot when TAC Vista Server (TACOS) runs as a service

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No license after reboot when TAC Vista Server (TACOS) runs as a service

Picard Product_Support
‎2018-09-11 01:10 PM

Last Updated: Administrator CraigEl Administrator ‎2022-08-10 10:11 PM

Issue

After rebooting the PC, TAC Vista Server (TACOS) doesn't get a license. You need to restart TACOS after each reboot to get a license.

Product Line

TAC Vista

Environment

  • TAC Vista License Server
  • TAC Vista Server

Cause

TAC Vista Server (TACOS) starts up before the license system is ready to serve licenses, and therefore everything is offline until you restart TACOS.

Resolution

Download these tools

TAC Vista Run Mode

TACLicenseServer Settings (only for TAC Vista 5.1.8 and later)

First of all, make sure that you have a system that is working normally and has the appropriate default settings. For more information, watch this video on YouTube

Make the following setting in TACLicenseServer Settings

[1] Set the startup type to "Automatic" and the taclic port to 2170

01_TACLicenseServer settings.png

[2] Click the "License Setup" button, and write the name or IP address of the local PC. Don't use "localhost" or 127.0.0.1 but the actual name or IP.

02_0_TACLicenseServer settings.png

 02_TACLicenseServer settings.png

[3] Click the "License Files" button, and check that only valid license file(s) is present in the license files folder - no other files can be in this folder.

03_TACLicenseServer settings.png

04_TACLicenseServer settings.png

[4] Start the license server

05_TACLicenseServer settings.png

Make the following setting in TAC Vista Run Mode

[1] Enter the username and password of a user with local administrator rights that have at some point been logged in on the PC. LocalSystem can be used, but it is not recommended.

01_TAC Vista Run Mode.png

[2] Set TACOS to run as a service

02_TAC Vista Run Mode.png

[3] In "Service Tools" set the service to start type "Automatic Delayed"

03_TAC Vista Run Mode.png

[4] Start the service

05_TAC Vista Run Mode.png

Now reboot the PC

If TACOS still doesn't get a license after a reboot, try making this additional setting in TAC Vista Run Mode

[1] Stop the service

06_TAC Vista Run Mode.png

[2] Make the service depend on the license server, and also the Loytec driver if it is used in the system.

04_TAC Vista Run Mode.png

Now reboot the PC

If TACOS still doesn't get a license after a reboot, try adding this environment variable to Windows

[1] Open the properties for the computer (Click the Windows start button, right-click "Computer", click "Properties")

[2] Click on "Advanced system settings"

Advanced System Settings.png

[3] Add a new system variable called "TCP_NODELAY" and give it the value 1

Environment Variable.png

Now reboot the PC

If TACOS still doesn't get a license after a reboot, contact Product Support Services and reference this article

Now reboot the PC

If TACOS still doesn't get a license try making this additional setting in TAC Vista Run Mode

Now reboot the PC

If TACOS still doesn't get a license try making this additional setting in TAC Vista Run Mode

Labels (1)
Labels:
  • TAC Vista
Attachments
TAC Vista Run Mode.zip
TACLicenseServer Settings.zip
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