Warning
Potential for Data Loss: The steps detailed in the resolution of this article may result in a loss of critical data if not performed properly. Before beginning these steps, make sure all important data is backed up in the event of data loss. If you are unsure or unfamiliar with any complex steps detailed in this article, please contact Product Support for assistance.
Issue
If the passphrase is incorrect when trying to install a station .bog, the following error message can appear;
Transfer failed.
com.tridium.platform.daemon.DaemonResponseException: Request to platform daemon at (stationName) failed:
bad return code to commit file instance
at com.tridium.platform.daemon.DaemonFileUtil.transfer(DaemonFileUtil.java:661)
at com.tridium.install.InstallScenario.commit(InstallScenario.java:1444)
at com.tridium.platDaemon.ui.stationtransfer.FinalStep.run(FinalStep.java:341)
at java.lang.Thread.run(Thread.java:750)
Product Line
TAC IA Series
Environment
- I/A Series N4 Enterprise Server
- I/A Series N4 Jace
Cause
The .bog has not been properly placed in the User Home / Stations for copying into the device or the passphrase is not known.
Resolution
- Always use the Station Copier to install the .bog from the User Home / Stations path
- If the error message appears, open Workbench and navigate to the "Stations" folder under the "User Home"
- Expand the station you are attempting to install
-
Double-click the .bog (1) and locate the "Bog File Protection" icon at the top of the page (2)
- Select the (1) "Force the File to start..." radio button and (2) Update. Note the information regarding existing passwords.
-
If the message "Cannot display page" occurs when you double click the .bog, open the "Details" and look for missing modules "Cannot load module '......=.....'. Any missing modules will need to be available on the Jace or ES before attempting the force start operation.