Issue
Niagara G3 station fails to send out emails and discards to the email with this error message: "BOutgoingAccount could not dequeue in-memory email: null"
Environment
Niagara G3 (AX) ENC and ENS stations (all versions)
Cause
After watching the output with debug turned on, the station connects to the email server and authenticates. When it tires to send out an email there is a null pointer exception and it discards the email. There is a trailing semicolon in the To Field of the EmailRecipient under Alarm Service. The email handler is looking for another email address after the last semicolon and sees a null when trying to add the last non-existent email address.
Resolution
Remove the trailing semicolon.