Issue
When service pin the device in LonMaker system plug-in, an error message pops up saying: Neuron ID has been used by another device, and NID went to all 0.
Environment
Cause
- some old device information got stuck in the database
- the device was added into the network earlier, and the user forgot about that
Resolution
- Delete the node/device from the network.
- Resynchronize the drawing with database.
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If the device comes back, then means some information was stuck in the database.
- Simply delete the device again.
- Resynchronize again to make sure it was truly deleted.
- Redo this procedure if needed.
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If nothing changes on the drawing, then the device was added into the network before, now you need to find where it was added.
- Open the Echelon LNS Report Generator (Start-> All programs-> Echelon LNS Utilities).
- Select the network
- Leave the rest sections as default.
- Click “Generate” to generate the report.
- Go to the “Report Filename” Path to open the “.csv” file.
- You can search the problem Neuron ID under NeuronId column.
With the information that report provide, you should be able to locate the node in the network. You can go back to your drawing delete it or keep it if that’s a necessary node.