Issue
The LCES firmware for MP is universal, covers all models. The LCES firmware learns its model from the STM32 (the IO processor). If the LCES FW is unable to get an answer to the question, "what model am I", it defaults to MPC15A. When we see this, the reason is usually due to missing/corrupt STM32 firmware caused by a power fail during an uprev of the STM32
Product Line
EcoStruxure Building Operation
Environment
- Multi-purpose Controller
- Multi-purpose VAV
- Multi-purpose IO
Warning
Potential for Data Loss: The steps detailed in the resolution of this article may result in a loss of critical data if not performed properly. Before beginning these steps, make sure all important data is backed up in the event of data loss. If you are unsure or unfamiliar with any complex steps detailed in this article, please contact Product Support for assistance.
Cause
STM32 flash corruption is caused by interruptions during firmware activation, such as:
- Power cycling the controller before activation completes.
- Network disruptions during upgrade.
- Premature assumption that upgrade is complete based on “100%” progress bar.
Resolution
To recover, try the following:
- Manually factory reset the MP controller (Press and hold the reset button between 20-29 seconds)
- Upgrade the MP controller to a revision close but NOT the same as the current firmware version.
- When the firmware upgrade is complete, reset the controller or power cycle the MP controller.
- Collect the device report again and check if the model has been updated to the correct one.
- If the model is correct, upgrade to the original or desired firmware version. If the model is incorrect, attempt another upgrade with a different version , aside from the initial firmware, from Step #2.
- You may need to repeat the firmware upgrade two more times if unsuccessful.