Issue
User can open the database in TAC Vista Workstation, but can not run the project database with an LNS network properly when it has been copied from the project site.
TAC Vista Workstation is extremely slow when the user operates it in a separate PC or laptop.
Product Line
TAC Vista
Environment
- Vista 5.1.X
- Windows Environment
- LonMaker / NL220
- Vista System Plug-In
Cause
In the user's PC or laptop, the Vista database can not find the proper LNS port which exists in the project site PC.
Resolution
- Define the database which was copied from the project site as the active database in the "Vista Database" tab in "TAC Vista Server Setup"
- Run TAC Vista Server application (TACOS.exe)
- Run TAC Vista Workstation. Wait a while for the TAC Vista Workstation to open the database completely
- Right click the LNS port. Wait a while for the right-click options to appear, then click "Properties"
- Record the port name in TAC Vista Workstation and its "Device address" in the properties window to a TXT file and save it.
- Delete all text in the "Device address" in the properties window, and click "OK" to accept the change
- Repeat steps 4, 5, and 6 to delete all LNS ports' "Device address"
After the last "Device address" has been deleted. The TAC Vista Workstation's response speed will be back to normal.
If some modifications have been made to the database and need to be applied in the project (which means the database would replace the project site database), remember to restore the "Device address" name according to the TXT file before restoring on the site PC.