Issue
JPEG image added to a TGML graphic displays in Workstation but not WebStation
Product Line
EcoStruxure Building Operation
Environment
- TGML
- SmartStruxure
- WebStation
Cause
It is possible there is something in the JPEG compression used for a specific image file that does not allow it to display in a web browser. The majority of JPEG images will work fine.
Resolution
- In Windows Explorer, right-click on the image file and select Open With
- Open with any image editing program more advanced than MS paint, for example, Microsoft Office Picture Manager
- Select File > Export (in some programs this may be under the Edit Menu)
- Any Export will force the file to re-compress. It may also be advisable to lower the quality of the JPEG export in some manner to ensure fast load times on the web.
- Save the file
- Edit the Graphic in the TGML Editor, click on the Content Property of the Image object
- Click on the "..." icon
- Select the newly compressed image file and click open
- Save the TGML graphic and view in Workstation and Webstation.