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Invalid database version. (Subsystem: LNS, #81)[DB #-2038]

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Invalid database version. (Subsystem: LNS, #81)[DB #-2038]

Picard Product_Support
‎2018-09-07 07:07 AM

Last Updated: Administrator DavidFisher Administrator ‎2020-11-17 06:51 AM

Issue

LNS81.png

 

Invalid database version. (Subsystem: LNS, #81)[DB #-2038]

Environment

LonMaker 3.1

Cause

A computer running LNS version 3.2 or higher (sometimes called LNS Turbo) can open any LNS database. If the database being opened is LNS version 3.1 or earlier, the database will be upgraded. This process is irreversible. Once the database is upgraded, earlier versions of LNS can no longer open it.

The opposite is not true. If a computer running LNS version 3.1 attempts to open a 3.2 database, this error will appear.

Resolution

The LNS version must be at 3.2 or later to open a 3.2 database. Either upgrade the LNS version on the PC attempting to open the database, or revert to an earlier version of the database before it was upgraded (if possible).

To upgrade your LNS version to 3.2:

  1. Navigate to http://echelon.com/support/downloads. You will need an Echelon ID and password. It is free to create a New User Account if you do not already have one.
  2. In the drop-down menu, select Search for software in the Network Tools category.
  3. Before you install LonMaker Integration Tool 3.1 Service Pack 3 Update 3, you must have already installed LonMaker Integration Tool 3.2 Service Pack 3 Update 1. Download both Update 1 and Update 3, or just Update 3 depending on the situation.
  4. Note: If you upgrade to LNS Turbo, you will no longer be able to restore databases from a non-Turbo LNS PC. There is backwards compatibility with old databases, but no "forward" compatibility for older PCs to open newer networks.
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