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InitCrypkey Error -103 or InitCrypkey Error -102 when running Checklic license utility

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InitCrypkey Error -103 or InitCrypkey Error -102 when running Checklic license utility

Picard Product_Support
‎2018-09-07 03:38 AM

Last Updated: Administrator DavidFisher Administrator ‎2019-10-07 08:40 AM

Issue

Error when running the Checklic license utility:

  • "InitCrypkey Error -103: NETWORK: REPLY FROM NETWORK DRIVER IS BAD"
  • "InitCrypkey Error -102: NETWORK: NETWORK DRIVER APPEARS TO NOT BE SERVING THIS DIRECTORY"

Product Line

Other, TAC Vista

Environment

  • LNS 3.0
  • LNS Turbo Edition (Ver 3.2)
  • LonMaker 3.0
  • LonMaker 3.1
  • LonMaker Turbo (Ver 3.2)
  • Vista

Cause

A problem has occurred with the LonMaker licensing.

Resolution

There are two procedures for fixing this problem. Try Procedure 1 first, and if the license still has the same problem, try Procedure 2.

Internet access may be required for Procedure 2 to in order to download the setupex.exe and cks.exe programs and request a replacement license.

Procedure 1:

  1. Confirm that the Windows Crypkey License service is started. To confirm, click Start > Control Panel > Administrative Tools > Services. Verify the Crypkey License status is Started. Also verify that the startup type is Automatic. If not, right-click the name and then click Start. Double-click the name to enter the properties dialog and change the startup type to Automatic. Close the Service window.  
  2. Confirm the Crypkey NetworkX driver is started by running C:\Program Files\Common Files\Microsoft Shared\MSInfo\Msinfo32.exe. Expand System Summary > Software Environment > System Drivers in the category tree in the left pane, then locate NetworkX in the right pane. Confirm that the State is Running and the Status is OK. Close the System Information window.
    If you cannot find these software components, uninstall the Echelon Software product, reboot, and reinstall the product. Antivirus and Internet security software can interfere with the proper installation of the software. Disable such software before you re-install the Echelon software product.
  3. At this point, if you are still unable to run your LonMaker or LNS application because of a License Access error message and if the Checklic license utility still reports a -102 or -103 error, follow the steps in Procedure 2.

Procedure 2:

  1. Check to see if two files exist in the C:\Windows\LNS Licenses folder.
    • setupex.exe
    • cks.exe
  2. The LNS Licenses folder is hidden; if you do not see it, open the Windows Explorer Tools menu, click Folder Options, and in the View tab, select Show Hidden Files and Folders and clear Hide Protected Operating System Files (Recommended). If you don't see these files, download them from Echelon and extract them to the C:\Windows\LNS Licenses folder.
  3. Open a Windows command prompt by clicking Start > Run and typing in cmd (or command for Windows 98).
  4. Type the following command to change your working directory: cd "\Windows\LNS Licenses"
  5. Type the following command: setupex /U
  6. Reboot the computer.
  7. Repeat steps 3 and 4, and then type the following command: setupex
  8. Reboot the computer.
  9. Open a Windows command prompt and enter "checklic lonmaker.vsl" for the LonMaker Tool or "checklic nsseng.exe" for other LNS tools and applications.
  10. If no errors appear, then the LNS application should start. Exit now.
  11. If the GetAuthorization Error -4/GetAuthorization Error -1 error is shown, which is expected, try opening/creating network. If the -4/-1 error remains, use the license wizard to request replacement credits.
  12. If the InitCrypkey Error -102/-103 error is shown, delete the following files under C:\Windows\LNS Licenses (do not delete other files from the LNS Licenses folder):
    • For the LonMaker tool:
      • LonMaker.rst
      • LonMaker.ent
      • LonMaker.key
      • LonMaker.41s
    • For an LNS tool or application other than the LonMaker tool:
      • nsseng.rst
      • nsseng.ent
      • nsseng.key
      • nsseng.41s
  13. Delete esnecil.ind in the C:\windows\system32 folder.
  14. Reboot the computer.
  15. Run the Checklic license utility again.
  16. If the GetAuthorization Error -4/GetAuthorization Error -1 error is shown, which is expected, try opening or creating a network. If the -4/-1 error remains, use the license wizard to request replacement credits.
  17. Once the license is fixed, download and install the LNS Licensing Update 2006.
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  • TAC Vista
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