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In Niagara R2 Workplace Pro, a Save Runtime DB command on a UNC does not work. This error message appears: "DB ADMIN COMMAND ERROR EXCEPTION; CONNECTION REFUSED".

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In Niagara R2 Workplace Pro, a Save Runtime DB command on a UNC does not work. This error message appears: "DB ADMIN COMMAND ERROR EXCEPTION; CONNECTION REFUSED".

Picard Product_Support
‎2018-09-06 02:55 PM

Issue

In Niagara R2 Workplace Pro, a Save Runtime DB command on a UNC does not work.  This error message appears:

"DB ADMIN COMMAND ERROR EXCEPTION; CONNECTION REFUSED".

Environment

  • Niagara R2 Workplace Pro
  • UNC

Cause

The UNC has its http port configured for a port number other than the default port of 80. A line must be added to the station.properties file to specify the new port number.

Resolution

  1. Open the admin tool and log into the UNC (not the station database).
  2. Right-click on the station name that indicates "running" and select Edit > Properties. The station.properties window will open (typically indicates autoStart=true and autoRestart=true).
  3. Add a line to this file that specifies the new port number.  For example, if the station database was configured to use port 8080, the line would read:  httpPort=8080
  4. Choose File - Close and Save when prompted.

NOTE: To enable this change, the UNC must be rebooted.

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