Issue
In Niagara R2, UNC will not archive to Enterprise Server.
The following errors are being displayed in the Enterprise Server’s Standard Output Window:
ERROR: LogService.archive: java.lang.IllegalStateException: Database not connected!
java.lang.IllegalStateException: Database not connected!
at tridium.services.DatabaseService.checkConnected(DatabaseService.java:389)
at tridium.services.DatabaseService.getConnected(DatabaseService.java:363)
at tridium.services.logService.archivelocal(LogService.java:13)
at tridium.log.service.RemoteArchiveHandler.handlerArchiveLog(RemoteArchiveHandler.java:95)
at tridium.log.service.RemoteArchiveHandler.handlerAaction(RemoteArchiveHandler.java:68)
at tridium.datax.net.DxExchange.doRequest(DxExchange.java:314)
at tridium.datax.net.DxExchange.Run(DxExchange.java:274)
at tridium.datax.net.DxServer.doGet(DxServer.java:80)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:499)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:588)
at tridium.foundation.net.TServiceThread.run(TServiceThread.java:195)
Also see the following in message in the Standard Output Widow of the UNC:
tridium.datax.net.DxRemoteException: java.lang.IllagelStateException: Database not connected!
at tridium.datax.net.DxExchange.doResponse (bytecode 107)
at tridium.datax.net.DxExchange.run (bytecode 118)
at java.lang.Thread.run (line5)
Environment
Enterprise Service (all versions)
Cause
The Enterprise Server’s Cloudscape database is corrupt.
Resolution
We can attempt to recover the database first. If it can not be recovered, it must be deleted or renamed.
Steps to recover the database app folder:
- Stop the Enterprise Server’s station database and open the Niagara console.
-
At the prompt, type in the follow: dbadmin "station name"
recover.
This will attempt to recover the database located in the station's app folder. -
Once complete, restart the station and check to see if you can successfully connect.
If this does not work, the database cannot be recovered and will have to be removed and / or deleted.
Steps to delete the cloudscape database app folder :
- Stop the station database
- Locate the app folder under the station folder, and delete the app folder or rename it with ".old" suffix
-
Restart the station.
The Cloudscape (app folder with file structure) will be automatically re-created.
The database should now show "is connected."