Issue
Java is no longer available or supported in most web browsers so accessing Niagara using the Java Applet is no longer possible
Product Line
TAC IA Series
Environment
- I/A Series G3 Enterprise Server/Jace 3.8U4
- I/A Series N4 Enterprise Server/Jace 4.4U3 and subsequent
Cause
Oracle announced the end-of-life of Java SE 8 (Standard Edition). As of January 2019, free public updates for commercial users are no longer available. Customers accessing Niagara with the Java Applet/Web Start are impacted by this change. Those who have upgraded to full HTML5 versions for your browser front-end will not be affected. For customers who use the Java VM and Java Web Start for their legacy systems, Tridium has developed a suitable alternative, the Niagara Web Launcher.
Resolution
The Niagara Web Launcher application is now available. You can download Niagara Web Launcher using the following link:
- 64-bit systems: Web Launcher for 64 bit, 32 bit OS
- 32-bit (-x86) systems: Web Launcher for 64 bit, 32 bit OS
Niagara Web Launcher download links are also available from the Niagara station login page.
Niagara Web Launcher support is included in Niagara versions:
- 4.4U3 –Included in (4.4.94.14).
- 4.7U1 - Included in (4.7.110.32)
Subsequent releases of Niagara 4 will include Niagara Web Launcher support.
A patch for Niagara 3.8 U4 can be downloaded from here. Copy web.jar module version 3.8.403.1 into the modules folder of your Niagara AX 3.8 U4 workbench or supervisor station. This module may also be installed on JACE platforms. To use Niagara Web Launcher, Web Start must be enabled in the Web Service of the station.